Technical Requirements

STATUTORY WARNING –
Please note that the contents provided through this platform is the sole property of ALLEN Career Institute Pvt. Ltd. Any unauthorized downloading of videos, taking screenshots of slides from lecture videos, broadcasting of live classes on open/public forum by any means, redistribution of recorded videos, study materials, test papers or any other information provided through this platform is strictly prohibited. Institute reserves its right to terminate the student in case found indulge in any such illegal activities and shall be penalised to the maximum extent of the laws.


ALLEN Plus

Basic System Requirements (H/W and OS) for ALLENPlus


 System Requirements –

  • An internet connection – broadband wired or wireless (3G or 4G/LTE)
  • Speakers and a microphone – built-in, USB plug-in, or wireless Bluetooth
  • A webcam or HD webcam – built-in, USB plug-in

Supported Operating Systems

  • macOS X with macOS 10.15 or later
  • Windows 10 (Home, Pro & Enterprise).

Supported browsers (Latest versions only)

  • Windows: Firefox, Chrome
  • macOS: Chrome

Processor and RAM Requirements –

ProcessorQuad-core 2Ghz or higher (Intel i3/i5/i7 or AMD equivalent)
RAMMin – 4 Gb

Note: Dual and single-core laptops have a reduced frame rate (around 5 frames per second). For optimum performance on laptops, we recommend a quad-core processor or higher.


Bandwidth Requirements –

The bandwidth used by ALLENPlus will be optimized for the best experience based on the participant‘s’ network. It will automatically adjust for 3G, WiFi, or wired environments.

Recommended bandwidth for recorded videos & live classes:

For Recorded Videos
  • For high-quality video: 600kbps (up/down)
  • For 720p HD video: 1.2Mbps (up/down)
  • For 1080p HD video: 3.8Mbps/3.0Mbps (up/down)
For Live Classes
  • For high-quality video: 2.0 Mbps/1000kbps (up/down)
  • For 720p HD video: 3.8Mbps/3Mbps (up/down)
  • For 1080p HD video: 8.0Mbps/8.0Mbps (up/down)
iOS and Android devices
  • Android: OS version 10 and above with latest security patches
  • iOS OS version 14 and above